package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(deviceToken|device_token|avatarid|avatarId|QPRDBAN1E|summary_text|continue_content)"\s*:\s*"((?:\\"|[^"])+)`)
var str = `JsonBody: {
"usable_methods" : [ "RANDOM_READER", "QR", "RABO_SCANNER" ],
"summary" : {
"summary_text" : "\n\t\t\n\t <link rel=\"stylesheet\" type=\"text/css\" media=\"screen,print\" href=\"https://betalen-acpt3.rabobank.nl/ideal-betaling/static/appls/ideal-front-end/ideal-betaling//css/rabo-ideal-payment-qr-ux.css\"/>\n <link rel=\"stylesheet\" type=\"text/css\" media=\"screen,print\" href=\"https://betalen-acpt3.rabobank.nl/ideal-betaling/static/appls/ideal-front-end/ideal-betaling//css/assets/default.css\"/>\n\t\t<link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"https://betalen-acpt3.rabobank.nl/ideal-betaling/static/appls/ideal-front-end/ideal-betaling//css/crmv_brit.css\" /> \n\t\t\n\n\n \t\t \n\n \t\t <table class=\"ideal-summary\" cellspacing=\"0\" border=\"0\">\n <thead>\n <tr>\n <th>Naar</th>\n <th>Bedrag</th>\n </tr>\n </thead>\n <tbody>\n <tr>\n <td>\n <strong>Legalname inzake TradeName\n </strong>\n </td>\n <td>\n <strong>€ 1,00</strong>\n </td>\n </tr>\n <tr>\n <td>This is a description</td>\n <td></td>\n </tr>\n </tbody>\n </table>\n\n\t\t \t\n\n\n <script type=\"text/javascript\">\n\t\t\twindow.onload = function() { document.title='Betalen met iDEAL'; }\n\t\t</script>\n\t",
"summary_lang" : "nl"
},
"selected_method" : "RABO_SCANNER",
"challenge_data" : {
"objectType" : "rabo_scanner_challenge"
},
"sign_button_text" : "xx"
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}