const regex = /(?:from|join|drop table|into)\s*"([^"]+)"\."([^"]+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:from|join|drop table|into)\\s*"([^"]+)"\\."([^"]+)"', 'gm')
const str = `select "a"."col_1" , "b"."col_2" from "advp"."accounts" a inner join "advp"."finance" b
drop table "gqd"."customers"
insert into "cvb"."stores" a where "a"."cols" = "some value"
drop table "dataset"."table_name" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}