package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*([a-z]\s|[a-z]$)+\s*$`)
var str = `a
a a
a a
a a
a a a
a
a a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}