$re = '/name0 [0-9a-fA-Fx]* [0-9a-fA-Fx]* 1 [1-9][0-9]*$/m';
$str = 'name0 0x3f700000 0x160000 1 0
name0 0x3f700000 0x160000 1 1
name0 0x3f700000 0x160000 1 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);