$re = '/^[A-Z]{3}(;\s*[A-Z]{3})*$/m';
$str = 'AAA;BBB
AAA; BBB
AAA
;AAA
AAA;BBB;
123;AAA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);