$re = '/\'{\$[^}]+}\'/m';
$str = '\'{$data}\', \'{$data2}\', \'{$res}\',\'{$blahblahblah}\'';
$subst = "?";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;