const regex = new RegExp('\\blocation:\\s*((?:(?!location:|unit|format).)+) (?:format )?unit (?:(?!location:).)+\\b12345566\\b', 'gmi')
const str = `location: Paris format unit no serial no 12345. location: New York format unit no serial no 45764. location: Delhi format unit no serial no 34573.
Location: FD130 New York GA Unit Serial Purchase Order Sales Order Make Model Amount Tax Total 12345566 Location: FD130 Roswell GA Unit Serial Purchase Order Sales Order Make Model Amount Tax Total 0130029964
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}