#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}.\d{2}.\d{4}\s\d{2}:\d{2}:\d{2};(\d{1,3},\d);(\d{1,3},\d);(\d{1,3},\d);(\d{3},\d);(\d{1,2},\d{3});([\d,]+);([\d,]+);([\d,]+);([\d,]+);(\d);$"
Local $sString = "30.10=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2020.10.30 08:54:44 =~=~=~=~=~=~=~=~=~=~=~=" & @CRLF & _
"30.10.2020 09:57:30;53,3;70,8;46,6;224,5;0,315;0,753;292,4336;407,8415;330,3333;2;" & @CRLF & _
"30.10.2020 09:57:31;7,6;20,1;18,6;224,8;0,089;0,376;292,4336;407,8415;330,3333;2;" & @CRLF & _
"30.10.2020 09:57:32;91,5;129,4;91,5;224,5;0,577;0,707;292,4336;407,8415;330,3333;2;" & @CRLF & _
"30.10.2020 09:57:33;91,5;129,4;91,5;224,5;0,577;0,707;292,4336;407,8416;330,3333;2;" & @CRLF & _
"30.10.2020 09:57:34;119,9;141,6;75,4;224,3;0,631;0,847;292,4337;407,8416;330,3334;2;" & @CRLF & _
"30.10.2020 09:57:35;119,1;140,9;75,3;224,2;0,628;0,845;292,4337;407,8416;330,3334;2;" & @CRLF & _
"30.10.2020 09:57:36;119,1;140,9;75,3;224,2;0,628;0,845;292,4338;407,8417;330,3334;2;" & @CRLF & _
"30.10.2020 09:57:37;119,9;141,9;75,8;224,2;0,633;0,845;292,4338;407,8417;330,3334;2;" & @CRLF & _
"30.10.2020 09:57:38;121,5;143,7;76,8;224,1;0,641;0,845;292,4338;407,8417;330,3335;2;" & @CRLF & _
"30.10.2020 09:57:39;121,5;143,7;76,8;224,1;0,641;0,845;292,4338;407,8418;330,3335;2;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")