using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"' # the start delimiter
([^\\']* # anything but the end of the string or the escape char
(?:\\. # the escape char preceeding an escaped char (any char)
[^\\']* # anything but the end of the string or the escape char
)*) # repeat
' # the end delimiter";
string input = @"'As we put our vision and dreams on paper in our business plan this year, , there are two things I am sure will help you succeed: Faith and a spirit of gratitude, and that means even being grateful for the bad days. When we use our superpowers in business, it’s really leveraging our God given purpose as we exchange goods and services for a fee. You have a winning combination when you can leverage God’s purpose on your life and use it to serve others through your business. What’s even more amazing is that God will send the provision you need to fulfill his called on your life. Now that doesn’t mean you know everything you need to know to be successful in business. But in the right season, God bless you and your business. Be available and listen to that still and quiet voice to guide as his vision manifests.
After nearly 17 years in business, I now know that God’s will is what is best for me. God has three answers for us: Yes, Not yet, and I have something even better for you. 2016 is the year of gratitude and abundance. If you are grateful for every little thing, he’ll give you even bigger things. One who has conquered failure and transcends fear, carries an undeniable power from within. As I share with you my 10 good bible verses ever business needs for 2016, focus on finding the joy in the journey.
Psalm 5:3 (NIV)
“In the morning, LORD, you hear my voice; in the morning I lay my requests before you and wait expectantly.”
Begin your day in prayer and meditation, so that you can maintain a peaceful outlook and not start your day in a race. Ask the Lord for the desires of your heart and believe that he will answer.
1 Thessalonians 2:12 (NIV)
“... Encouraging, comforting and urging you to live lives worthy of God, who calls you into his kingdom and glory.”
No matter how successful we become in business, we must always seek to be shinning examples of God’s light and love.
Proverbs 18:13 (NIV)
“To answer before listening — that is folly and shame.”
We have two ears and one mouth for a reason. It’s always best to listen first in any situation and speak last, after you’ve had time to consider fully what has been said.
Philippians 3:13-14 (NIV)
“Brothers and sisters, I do not consider myself yet to have taken hold of it. But one thing I do: Forgetting what is behind and straining toward what is ahead, I press on toward the goal to win the prize for which God has called me heavenward in Christ Jesus.”
It is very important that we as Christians remember always, that we love a God who is a God of first, second, third, forth, and one hundred or more chances, if we need his forgiveness. It is important that we forgive ourselves quickly, and not dwell in our past mistakes.
1 Timothy 6:12 (NIV)
“Fight the good fight of the faith. Take hold of the eternal life to which you were called when you made your good confession in the presence of many witnesses.”
Faith is key in business and in a lifetime of happiness. For those of us who are believers, it is important that we witness to non-believers what God has done for us. He died for us on the cross, so that all sin is forgiven, and that we would have everlasting life.
Subscribe to The Morning Email.
Wake up to the day\'s most important news.
address@email.com
II Corinthians 12:9-11 (NIV)
“But he said to me, my grace is sufficient for you, for my power is made perfect in weakness.” Therefore I will boast all the more gladly about my weaknesses, so that Christ’s power may rest on me. That is why, for Christ’s sake, I delight in weaknesses, in insults, in hardships, in persecutions, in difficulties. For when I am weak, then I am strong.”
It is in our weakness that God makes us strong. So we will always have challenges because it is in those times God wants us to lean on him for strength.
Psalm 37:23-24 (NIV)
“The LORD makes firm the steps of the one who delights in him; though he may stumble, he will not fall, for the LORD upholds him with his hand.”
Running your business will challenge you in ways you never considered. There will be days when you stumble, but God will always be there to catch you and lift you back up.
Romans 8:18 (NIV)
“I consider that our present sufferings are not worth comparing with the glory that will be revealed in us.”
You can’t have a testimony without a test. In business, it’s all about upfront sacrifice for long-term gain. What God requires of us is present suffering for future glory in heaven. God wants us to have confidence that he knows the desires of our hearts and he will resolve our issues in his perfect time.
Jeremiah 29:11 (NIV)
“For I know the plans I have for you, plans to prosper you and not to harm you, plans to give you hope and a future.”
Every step in life and in business had already been ordered for us before we were even born. God does not reveal his plans to us all at once, because we could not handle it. He gives us a just glimpse though visions and dreams, but he plans for us to all live a prosperous life.
Psalm 23: 5-6 (KJV)
“... Thou preparest a table before me in the presence of mine enemies: thou anointest my head with oil; my cup runneth over. Surely goodness and mercy shall follow me all the days of my life: and I will dwell in the house of the LORD forever.”
When you are in business you will develop haters, but it is important that you realize that you don’t have to handle your detractors yourself. God will bless you right in front of them. All you can do with your haters is pray for them.
I often stop during my workday to thank God who has been so good to my family, my business and me; it makes me tear up when I think about his goodness.. These scriptural references have helped me have hope throughout my life in business. I hope the verses from the Bible, and my translation, have encouraged you. Many times it’s hard for us to pitch our tent in the world, but God sees you. He loves you and if you give him your life to him, he will give you the desires of your heart. Keep going!
May God Bless You in Your Business.'";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}