$re = '/\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b/';
$str = '999.999.999.999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);