package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/a\/.*\/x\..*$`)
var str = `/a/yo/x.ts`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}