package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]`)
var str = `ID=123456&stb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}