package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-?\b\d+(,\d+)*(\.\d+(e\d+)?|e\d+)?\b`)
var str = `This text has random numbers, 125.25 and -1,101,045,521.12 are float numbers; 1.5899e23 and 10e8 are in scientific format; the numbers 3,340 and -562 are integers, and 720p is a video quality value.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}