re = /(^|\s)#[A-Za-z0-9]*/m
str = '#ciao
#101
#amore
@fatto
https://regex101.com/#ciao
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end