package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(.+?)\s*(.*?)\s*>(.+)<.+>|<\/?(\w+)\s*(.*?)\s*\/?>`)
var str = `<div>
\`hello\`
if (test) {
<p>ok</p>
}
else {
<a href="home" >home</a>
<idfd dfd="href" />
}
</div>
(<div>)
<>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}