#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:BP:?(?:-Sitting)?|Blood Pressure) \d+(?:/\d+){0,2}(?: ?\d+(?:/\d+){0,2})*(?: sm| -Lw| cB| Jr|\" & @CRLF & _
" -aA| cs| -ic| ic| -RG| kA| -sL| BL| kc| am| -sH| sH| es| ts| np| 8s| ca| Pm| JE| so| cp| v8| Eu| -cp|\" & @CRLF & _
" Pm| EB| Fr| -Fr| -ms| -LN| -mT| -mk| -GF| -HO| Jp| wD| 8m| mc| -mc| Yr| -Lp| -ml| -LA| s/d| -aA| s/d|mmHg| mm Hg|\" & @CRLF & _
" mm hg.)?|B/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+|(?<!DOB )\d{2}/\d{2}/\d{4}\b"
Local $sString = "Bodu Mass Index 21.5 07/27/18 Blood Pressure 134/78 07/27/18 Position Sitting BP 10/30/17 1345 178/80" & @CRLF & _
"Amett Hayley MR# 70583797 DOB 07/14/1962 Encouter Date 02/21/2018 BP 136/88 Site Left Arm Cuff Size Large"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")