$re = '/(?!:\W)(\-)?(\d+)[.]?(\d+)?/m';
$str = '23+-22.2222+-2334+45+2+5-1/22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);