$re = '/\B(?=(?:\d{3})+(?!\d))/m';
$str = '123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);