#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^.#,]*[.#,].*?\bMY_STRING\b[^,\r\n]*;(?:video|comment)(*SKIP)(*FAIL)|\bMY_STRING\b"
Local $sString = "[1]" & @CRLF & _
"text,MY_STRING ;comment " & @CRLF & _
"text,MY_STRING text ;comment " & @CRLF & _
"text,text MY_STRING text ;comment " & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"-> dont catch any above because exist a" & @CRLF & _
"**comma** before #MY_STRING# and ;comment after." & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[2]" & @CRLF & _
"text, MY_STRING , text ;comment " & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"-> catch because exist a **comma** after #MY_STRING#" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[3]" & @CRLF & _
"text, MY_STRING, MY_STRING ;comment" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"-> catch first #MY_STRING# but don't catch last #MY_STRING#" & @CRLF & _
"because she is between , and ;comment" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[4]" & @CRLF & _
"MY_STRING" & @CRLF & _
"MY_STRING,text" & @CRLF & _
"text, MY_STRING," & @CRLF & _
"MY_STRING ;comment " & @CRLF & _
"text MY_STRING ;comment " & @CRLF & _
"text,MY_STRING,text ;comment" & @CRLF & _
"%MY_STRING% , (MY_STRING)" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"-> catch all, because there's no [comma . #] preceding #MY_STRING#" & @CRLF & _
"and no [# ;comment ;video] succeeding" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[5]" & @CRLF & _
".MY_STRING" & @CRLF & _
"#MY_STRING" & @CRLF & _
"MY_STRING#" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"- > dont catch any" & @CRLF & _
"Independent of where MY_STRING is, either what it has between, don't catch any, because they have . or # preceding/proceeding the string." & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[6]" & @CRLF & _
"MY_STRING, .MY_STRING, #MY_STRING, text, MY_STRING" & @CRLF & _
"text, MY_STRING#, MY_STRING, .MY_STRING" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"-> same as above, just catch MY_STRING samples not containing . #" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[7]" & @CRLF & _
"text, MY_STRING ;video" & @CRLF & _
"MY_STRING ;video" & @CRLF & _
"#MY_STRING, MY_STRING, text, text MY_STRING ;video" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"- > In this case, the string will not be caught independent of where it is or what it has preceding/succeeding because exist the string ;video at the ending." & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[8]" & @CRLF & _
"text,MY_STRING, text ;comment" & @CRLF & _
" ^ ok catch (reason explained above)" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[9]" & @CRLF & _
"text,MY_STRING@ text ;comment" & @CRLF & _
"-------------------------------------------------------------- ^ dont catch, because there's no comma after the string, and there's a comma before and ;comment after" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[10]" & @CRLF & _
"MY_STRING,text,#MY_STRING,text,text,%MY_STRING% @ $text #text <text> ;comment" & @CRLF & _
"^[1] ^[2] ^[3]" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"[1] catch" & @CRLF & _
"[2] don't (# preceding)" & @CRLF & _
"[3] don't catch, because there's a comma preceding, no comma succeding and at the end line exist the string ;comment" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[11]" & @CRLF & _
".MY_STRING,text,MY_STRING,text,text,%MY_STRING% @ $text, #text <text> ;comment" & @CRLF & _
"^[1] ^[2] ^[3] ^[4]" & @CRLF & _
"--------------------------------------------------------------" & @CRLF & _
"[1] don't (dot preceding)" & @CRLF & _
"[2] catch" & @CRLF & _
"[3] catch because there's a comma on [4] so the string is not anymore between a comma preceding and ;comment succeeding, she is now between a comma preceding a comma succeeding and ;comment"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")