$re = '/(\$\{)(.*)(\:.*)(\})/m';
$str = '${place.holder}
${place.holder:defValue}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);