using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<username>[a-zA-Z0-9.-_]+)@(?P<domain>[a-zA-Z0-9.-_]+)\.(?P<ltd>[a-zA-Z0-9-_]+)";
string substitution = @"<a href=""mailto:\0"">${username}</a>";
string input = @"The mail or post is a system for physically transporting postcards, letters, and parcels.[1] A postal service can be private or public, though many governments place restrictions on private systems. Since the mid-19th century,yvannak54@gmail.com national postal systems have generally been established as a government monopoly, with a fee on the article prepaid. Proof of payment is usually in the form of an adhesive postage stamp, but a it123@gmail.com postage meter is also used for bulk mailing. Modern private postal systems are distinguished from national postal agencies by the terms ""courier"" or ""delivery service"".
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}