const regex = /^.{1}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{1}', 'gm')
const str = `Notepad++
For notepad++, a Windows text editor, the InsertLoremIpsumNppPlugin can be downloaded at twenfour.com. It generates and inserts Lorem Ipsum, either as words, sentences, or paragraphs. The installation requires to copy the file InsertLoremIpsumNppPlugin.dll and the Config directory (both are contained in the zip file) to the "plugins" subdirectory of the Notepad++ installation directory. Afterwards, a new option "InsertLoremIpsum" will show in the "plugin" menu entry. A restart may be required. >> screenshots
ToolBucket: This plugin allows for base 64 encoding, it has a change indentation dialog, it generates Lorem Ipsum and has many more features.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}