# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"PJ\s?[=:]\s?\{(.*\s*\})"
test_str = ("h=function(a,b){var c=this.index.fh(a);b&&(c=Math.min(this.index.Bc(),c+1));return MJ(this,c,this.index.po(c),0)};\n"
"g.h.rs=function(){var a;if(a=this.Cd()&&!(0,window.isNaN)(this.l))a=this.index,a=(a.o?a.g[a.Ia]:-1)!=this.l;return a};\n"
"g.h.xe=function(){return!0};\n"
"g.h.tc=function(){return!1};\n"
"g.h.fr=function(){return this.indexRange.length+this.initRange.length};\n"
"g.h.Wt=function(){return this.indexRange&&this.initRange&&this.initRange.end+1==this.indexRange.start?!0:!1};var PJ={yF:function(a,b){var c=a[0];a[0]=a[b%a.length];a[b]=c},\n"
"It:function(a){a.reverse()},\n"
"yp:function(a,b){a.splice(0,b)}};g.p(RJ,g.kF);g.h=RJ.prototype;g.h.Mf=function(){return Mb(this.g,function(a){return a.info.video?2==a.info.video.projectionType:!1})};\n"
"g.h.Nf=function(){return Mb(this.g,function(a){return a.info.video?3==a.info.video.projectionType:!1})};\n"
"g.h.Le=function(){return Mb(this.g,function(a){return a.info.video?4==a.info.video.projectionType:!1})};\n"
"g.h.ji=function(){return Mb(this.g,function(a){return a.info.video?1==a.info.video.stereoLayout:!1})};\n"
"g.h.wS=function(a){var b=a.getElementsByTagName(\"Representation\");if(0<a.getElementsByTagName(\"SegmentList\").length||0<a.getElementsByTagName(\"SegmentTemplate\").length){this.A=!0;this.B||(this.B=new ska);wk\n\n"
"var PJ={yF:function(a,b){var c=a[0];a[0]=a[b%a.length];a[b]=c},It:function(a){a.reverse()},yp:function(a,b){a.splice(0,b)}};")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.