re = /\D\d{5}\D/
str = 'four digits 1234 five digits 56789 six digits 01234,56789,01234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end