package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)donglin tang
`)
var str = `
https://regex101.com/r/E2CxQ6/1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}