$re = '/^(?!0+(?:\.0+)?$)(?:200|200.0|200.00|[0-1]{0,1}[0-9]{1,2}(?:\.[0-9]{1,2})?)$/m';
$str = '0.01
200
200.0
200.01
200.012
200.00
188.21
1.2
0.12
0.00
-12
67.23
234.5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);