use strict;
my $str = '/**
* @param Test
* @param Test
* @param Test
* @param Test
*/';
my $regex = qr/[*\s]* # multiple space or asterisk characters
@ # followed by the @ sign which
(?P<name>[\w\\]+) # has a string of \w or \ characters following it
\s*\(? # separated by spaces and maybe opening parenthesis
(?P<value> # store the value attached to the named annotation
(?:
[^@]* # value is made of enlisted characters
[^*\s)] # but does not end with
)
)? # the value is optional parameter
(?:\s|\n|\))/sxmup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}