re = /<@[^:]+:/m
str = '<@edi:outOperatorVoyageNbr>V4</@edi:outOperatorVoyageNbr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end