re = /^\(\p{Nd}\)\s+(.+)\n(\(\p{L}\).*?)।\s+Ans\s+\((\p{L})\)/m
str = '(1) Capital of Bangladesh is-
(A) Dhaka (B) Rangpur (C) Chittagong (D) Comilla। Ans (A) Dhaka
(2) Largest city of Bangladesh is-
(A) Mirpur (B) Rangpur (C) Chittagong (D) Comilla। Ans (C) Chittagong
(3) Smallest city of Bangladesh is-
(ক) বাংলা (খ) ইংরেজি । Ans (B) Rangpur'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end