$re = '/(?:(?:(?:\d+)g|(?:g\d+))|(?:(?:l\s*\d+)|(?:\d+\s*l))|(?:(?:\d+,\d+\s*Kg)|(?:kg\s*\d+,\d+)))/m';
$str = 'ABC 200g EFG 5,4 Kg HIL 2x20l
ABC g200 EFG kg 5,4 HIL l 20x2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);