$re = '/ : .*?\K : /m';
$str = 'billy.baby : ya fake one billy.baby : ya fake one';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);