re = /^373(?=\d{9}$)(11|222)\d+$/m
str = '37311012345
373110123456
3731101234567
37322201234
373222012345
3732220123456
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end