re = /^[ ]*((add|sub)[ ]+(a\d+)[ ]*,[ ]*(a\d+)[ ]*,[ ]*(a\d+)|(ecall))[ ]*$/m
str = 'sub a0,a2,a3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end