re = /\b((?:0[1-46-9]\d{3})|(?:[1-357-9]\d{4})|(?:[4][0-24-9]\d{3})|(?:[6][013-9]\d{3})|(?:\d{4}))\b/i
str = '6000 Lucerne 1 PF'
# Print the match result
str.match(re) do |match|
puts match.to_s
end