package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w_]+)`)
var str = ` TEAM_GANG,
TEAM_MAFIA,
TEAM_GANGSTER
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}