re = /(\((\((\(.*?\))(\(.*?\))\)).*(\(.*\))\))/m
str = '(((a+b)(c+d))+p(q*2+r))/2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end