$re = '/^(?!Mr).*(Approved).*/m';
$str = 'Abc your request is Approved
Mr. Abc your request is Approved.
In above statement if word \'Approved\' comes in sentence it should select whole sentence.
Abc your request is Approved.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);