import re
regex = re.compile(r"(?<=\d)(?=(\d{3})+(?!\d))")
test_str = ("30000\n"
"30000000\n"
"546789101\n"
"3000.11")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)