$re = '/(?<!\s)^|$(?!\s)/m';
$str = 'Line 1
Line 2
Line 3
Line 4
Line 5
Line 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);