$re = '/(?<!:)(?:::)*\K;/m';
$str = 'foo;bar:;baz::;one:two;::three::::;four;;five:::;six;:seven;::eight';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);