$re = '/[\d]+[,|.]?[\d]+[\ ]?[В]?[В|т]/m';
$str = 'SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ±1% 0.1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0.1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ±1% 0.11 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0.11Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX
50.9В
50.99Вт
50.9 В
50.999 Вт
а50ю
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);