using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b0(?!1*~)|([0-1])(?=1*~[0-1]*?\1([0-1]))|~[0-1]*";
string substitution = @"$2";
string input = @"0101~010";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}