import re
regex = re.compile(r"(?:(?!\u0301)[\W\d_])+", flags=re.MULTILINE)
test_str = "Андре́й Серге́евич Арша́вин (род. 29 мая 1981[4], Ленинград) — российский футболист, бывший капитан сборной России, заслуженный мастер спорта России (200"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)