using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)(?:\.\((\d{4}\-\d{2}\-\d{2}\s)?([^\)]*)\))?(?:\.(.+))?";
string input = @"Avatar 2 - la voie de l'eau.(2022-12-14)
Prey.(2022-08-05 Disney+)
Star Wars- The Clone Wars.(2008-08-27).Animation";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}