import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n(Contemporaine vermeldingen)\\s((\\[|cfr).*)\\n";
final String string = "(6476) t.e.m. (6478) en archiefgegevens verwerkt in genealogie \n\n"
+ "Overlijden:\n"
+ "Overleden eind 1463 of begin 1464: op 13/3/1465 werd gezegd dat hij al anderhalf jaar dood was (2906)\n"
+ "Zijn erfgenamen, die zijn erfenis mochten aanvaarden \"onder het voorrecht van boedelbeschrijving\" waren mr. Jan de Keghele en zijn vrouw Catharina van Steelant (2906)\n\n"
+ "Contemporaine vermeldingen [hier zitten duidekijk ook personen tussen uit de burgerlijke Ieperse familie Van Diksmuide, maar ook uit het adellijk geslacht Van Beveren, die eerder burggraven van Diksmuide waren; het is moeilijk deze allemaal te onderscheiden]\n"
+ "- Jacques, heer van Diksmuide, schildknaap, afgevaardigde van de Vlaamse adel op de Statenvergadering van 1464 (3797)\n"
+ "- Joos van Diksmuide, leenman en lid van het leenhof van de Oudburg van Gent v1486 (3868); werd in 1488-1489 geconfisqueerd voor kleine pachtprijzen; schepen van de keure 1485, 1493, 2de ontvanger 1495 (4308)\n"
+ "- magister Johannes de Dixmuda, advocaat die in 1480/81 voor de bisschop van Doornik pleitte voor de RVV (4597)\n"
+ "- Marie Dicquesmue, priores van het dominikanessenklooster Abiette te Rijsel 1450-1467 (4673)\n"
+ "- Marie Dicquesmue, 72 jaar zuster in dit klooster, op het einde priores, gestorven 1425 (4673)\n"
+ "- Anne de Dicquesmue, dochter van wijlen Pol, 60 jaar zuster in dit klooster, gestorven 1436 (4673)\n"
+ "- Marguerite de Dicquesmue, dochter van wijlen Olivier, ingetreden in 1367, werd onderpriores, gestorven 1437 (4673)\n"
+ "- in 1471 kwam er een proces voor de GR tussen de weduwe en erfgenamen van Jaques de Bevre, heer van Diksmuide enerzijds, en Clare de Florens, weduwe van Roeland, eveneens heer van Diksmuide: een beroep tegen een vonnis van de RVV waarbij aan de verweerster een recht van vruchtgebruik werd toegekend ten laste van de heerlijkheid Diksmuide; het beroep werd ongegrond verklaard (4770)\n"
+ "- Thierry van Beveren, burggraaf van Diksmuide [zoon van Henri, raadsheer van Lodewijk van Male; huwde een dochter van sire de Dolhain; ridder; dit was de vader van Johanna van Beveren, Daniël Alaerts' 2de echtgenote!] vraagt voor zijn broer Petrus Fouquet [clericus van het bisdom Doornik] een kanunnikaat met prebende in de Sint-Germanuskerk te Mons v1380 (5734)\n"
+ "- Hendrik van Beveren, heer van Diksmuide, ridder, vroeg voor zijn kapelaan Johannes Mercherius, priester uit het bisdom Terwaan, een beneficium afhankelijk van het Sint-Salvatorskapittel te Harelbeke v6/12/1391(5735) \n"
+ "- Hendrik van Beveren vroeg voor diezelfde ook beneficium afhankelijk van het Sint-Pieterskapittel te Rijsel v 2/12/1391 (5737)\n\n\n"
+ "Antecedenten en origine:\n"
+ "- vermoedelijk gaat het om een Brugse familie, maar Joris de Bul heeft zich zelf duidelijk voornamelijk in Gent opgehouden, waar hij ook was gehuwd \n"
+ "- Pieter de Bul, schepen van Brugge v1349 (4449)\n"
+ "- Philips de Bul, bevond zich in een hoge fiscale klasse in 1394-1396, meersenier, maner van de korenmarkt 1403, deelman van het OLV-zestendeel 1397, en van Sint-Jacobs 1400 (4520)\n"
+ "- Pieter de Bul, de oudere, zeer hoge fiscale klasse, meersenier, maner van de merseniershalle 1402, deelman OLV-zestendeel, bezat 15 huizen in Brugge; zijn zoon Pieter de jonge, eveneens meersenier (4520) \n"
+ "- men vroeg voor Johannes Bul [clericus bisdom Terwaan] een beneficium afhankelijk van het Sint-Pieterskapittel te Kassel v1387 (5753)\n"
+ "- Pieter en Josse de Bul streden in 1436 in de Brugse militie onder kapiteins Jan van Steenhuize en Clais de Calkere tegen de Engelse bedreiging aan de kust (6478) (7931); Pieter de Bul, meersenier, werd beboet omdat hij als Brugs poorter tijdens de opstand van 1436-1438 de stad was ontvlucht; in 1437 leidde hij met andere ballingen en met Jan van Uutkerke raids op de voedseltoevoer aan de rebellen (7931)\n"
+ "- Jacob en Pieter de Bul, broers uit Brugse \"handelaarssfamilie\" ; Pieter had een zoon Jan, die hoofdman was te Brugge in de jaren 1420, huwde met Clara de Baenst en stierf in 1449 (6272) \n\n"
+ "Familie:\n"
+ "Broers: Jacob en mr. Pieter (6475); mer [sic] Pieter de Bul, hoofdschepen keure 1461 (6983)\n\n"
+ "Huwelijk:\n"
+ "Gehuwd met Katelijne Sersanders, dochter van Filips Sersanders en Catherine Utenhove, zuster van de raadsheer mr. Jan Sersanders (2471) (6476) (7550)\n\n"
+ "Netwerken:\n"
+ "- het was hij die na de opstand van 1436-1438 de Brugse remissiebrief e.d. schreef, waarmee hij 100 lb par verdiende (5378)\n"
+ "- hij - en andere secretarissen - kregen regelmatig geld van steden voor schrijfopdrachten, bv. van Brugge (7537)\n"
+ "- Jan de Bul nam in 1446 deel aan het Brugse tournooi van de Witte Beer, o.a. samen met Filips van Artrijke e.a. leden van het Brugse patriciaat (6478)\n"
+ "- hij was financieel verbonden met zijn schoonfamilie Sersanders (6477)\n"
+ "- in 1451 werd hij ervan beschuldigd 30 lb gr stedelijk geld te hebben verduisterd en er nog eens 30 lb gr te hebben ontvangen als herenkiezer om Filips Sersanders tot voorschepen te benoemen en Pieter Hueribloc tot ontvanger (7440)\n"
+ "- bij de verdeling van de goederen van zijn vader in 1473 was naast Pieter Boudins en zijn broers ook Jacob Donche aanwezig (6476)\n"
+ "- hij was de neef van Pieter Boudins, secretaris van de hertog (2471)\n"
+ "- raadsheer Jacob Donche wordt eveneens vermeld onder zijn vrienden en magen (2471)\n"
+ "- hij koos in 1449 partij voor de hertog en manipuleerde samen met Pieter Boudins de schepenverkiezing van dit jaar; samen met de Gentenaars Pieter Tyncke, Lievin Wycke en Eloy Coolbrant organiseerden ze een samenzwering om deken Daneel Sersanders en Lieven de Potter en Lieven Sneevloet, tegenstanders van de hertog, te liquideren; onder de slogan \"Neerynghe, paeis ende vrede, ende onsen gheduchten heere in de stede\" hadden ze via een geheim onderhoud in Bergen, Henegouwen en tijdens vergaderingen in Brussel en in Gentse herbergen mannen gemobiliseerd o.l.v. Pieter Tyncke, om Sersanders dood te slaan in een \"wapeninge\" \"ende meester Pieter ende meester Joorys zouden hemlieden bistandichede doen met haren vrienden ende seiden dat zy vele vrienden hadden binnen der stede\"; wel meer dan 50 invloedrijke personen zouden de actie dekken, in deze context wordt ook gesteld dat \"de haude bende\", m.a.w. de tot dan heersende bestuurskliek, hen zou ondersteunen; op 11/12/1451 werd Joris de Bul - ondertussen reeds gevlucht - uit Gent verbannen en werden zijn goederen aangeslagen; er kwam een prijs van wel 1000 lb gr op zijn hoofd en dat van Pieter Boudins; na de onderdrukking van de opstand was hij in 1455 opnieuw kiesheer in de stad (2471) (7440) (7507); er zou zelfs een plan van enkele Gentenaars zijn geweest om hem en Boudins in Brussel te gaan vermoorden (7489)\n"
+ "- mr. Pieter de Bul was voogd van Joostin Meeux i.v.m. een leen te Assenede Ambacht v1473 (6477)\n\n"
+ "Overlijden:\n"
+ "Gestorven vermoedelijk in 1471 of 1472: zijn laatste vermelding in de registers van de RVV dateert van 25/1/1471 (2471); volgens grafschrift op 12/3/1471 (3278)\n\n"
+ "Contemporaine vermeldingen:\n"
+ "- Jacob de Bul, kocht een leen, vermeld na 1384; wellicht was hij lid van een handelaarsfamilie uit Brugge, overleed kort voor 1421, waarna zijn neef Jan, zoon van Pieter - waarschijnlijk de broer van Jacob - het leen overerfde (6272)\n"
+ "- deze Pieter de Bul, hoofdman te brugge in de jaren 1420, gehuwd met Clara de Baenst, stierf in 1449 (6272)\n"
+ "- Jan de Bul, zoon van Pieter, droeg het Brugse stadswapen in de H. Bloedprocessie, midden 15de eeuw (6272)\n"
+ "- Wouter de Bul, bode van de RVV, inwoner van Gent v1410-1413 (4023)\n"
+ "- Jan de Bul, raadslid van Brugge 1460, 1463 (5347)\n"
+ "- Jan of [Joos?] de Bul, raadslid van Brugge 1471 (4172)\n"
+ "- Joost de Bul, raadslid van Brugge 1465 (5347)\n"
+ "- Jacob de Bul, schepen van gedele te Gent 1476 (4306)\n"
+ "- mr. Pieter de Bul, secretaris van de keure 1455-1464, herenkiezer 1461, secretaris van gedele 1470-1476, secretaris van de keure 1476-1477, geconfisqueerd in 1488-1489 (4306)\n"
+ "- Gautier de Bul immigreerde in 1439 in Sint-Winoksbergen (4535)\n"
+ "- Jeanne II de Bul, cantrice [1465] en abdis van de Guldenbergabdij te Wevelgem [1478 - afstand 1487, gestorven 1497] (5752)\n"
+ "- Jacob de Bul, 11de schepen gedele Gent 1476 (6983)\n\n"
+ "(6495), (6496) en archiefgegevensverwerkt in genealogie \n\n"
+ "Antecedenten en origine + Familie: cfr. ook Daniel Alaerts\n"
+ "Vader: Perceval Alaerts, zoon van Daniel; moeder jonkvrouw Margriet van der Beerst (2975) (6495)\n"
+ "Tussen 1191 en 1429 waren de heren van Diksmuide uit het geslacht Van Beveren gekomen, daarna ging de titel via overerving naar het geslacht Van der Beerst; Beerst is een deelgemeente van het huidige Diksmuide; in 1508 tenslotte ging de titel weer over naar de familie Sacquespee (7520)\n\n"
+ "Huwelijk:\n"
+ "Gehuwd met vrouwe Clare van Florencen (6415)\n\n"
+ "Nageslacht:\n"
+ "Hij is kinderloos gestorven (6429)\n\n"
+ "Netwerken:\n"
+ "- in 1439 was hij samen met Joris de Wulf voogd van de wezen van Christoffel de Muelnaere te Ieper (4579)\n"
+ "- \"conync\" van de kruisbooggilde in Diksmuide v1450-51 (2973)\n"
+ "- in oktober 1450 trouwde hij, waarbij de stad Diksmuide voor hem, zijn echtgenoot en anderen een banket aanbood en hem 300 lb par schonk; speciaal voor hem kocht de stad voor haar schepenen nieuwe kledij, wat men al jaren wegens financiële tekorten hadnagelaten (2975) \n"
+ "- hij had in 1450-51 ook lange tijd aan het hof verbleven in het gezelschap van de heer van Croÿ (2975)\n"
+ "- in 1461 zouden de burggraaf en schepenen van Diksmuide misgrijpen en delicten hebben begaan tegen de heerlijkheid van de hertog en het gemenebest van haar inwoners (7723)\n\n";
final String subst = "\\n## $1\\n\\n$2\\n\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}