$re = '/\{\{(.*?)\}\}\s*((?:[A-Za-z0-9!#$%&\'*+\/=?^_`{|}~.+-])+@(?:(?:[A-Za-z0-9-])+?\.)+(?:[A-Za-z0-9]{2,})+)\s*\{\{\/(\1)\}\}/s';
$str = '{{foreach}} mail-1@mail.com {{/foreach}}
{{foreach}} mail-2@mail.com{{/foreach}}
{{foreach}}
mail-3@mail.com
{{/foreach}}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);