import re
regex = re.compile(r"^<()(?R){2}>\z|\1\Q^<()(?R){2}>\z|\1\Q")
test_str = "<^<()(?R){2}>\\z|\\1\\Q^<()(?R){2}>\\z|\\1\\Q>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")