re = /[a-z\d]+(?:[-_’',.][a-z\d]+)*/i
str = '_ - – hel’lo’ hel\'lo\' .1 1.0 1. hello, hello- world. he,llo hello-world hello_world hel-lo-world hello9world -20 20- 20-year -20year- -20-year- 20-year-old 20-yearold 20year-old 20-year-old-old 20-20-year-20-old-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end