re = /.*\b((?:(?!666|000)[0-8][0-9_]{2}[.-]?(?!00)[0-9_]{2}[.-]?(?!0000)[0-9_]{4}|[0-9]{9}))\b.*
/m
str = '555816693
553058963
483887047
368788230'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end