// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Insurance(?:[\s\S]*)\[(\d+)\](?:[\s\S]*)Insurance").unwrap();
let string = "<td class=\"th-clr-cel th-clr-td th-clr-pad th-clr-cel-dis\" style=\"width:226px; text-align:left; \">
<span class=\"th-tx th-tx-value th-tx-nowrap\" style=\"width:100%; \" title=\"Social Insurance Number (SIN)\" id=\"C29_W120_V121_builidnumber_table[5].type_text\" f2=\"C;40\">
Social Insurance Number (SIN)
</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}